Error Message

Topic's about PicSender
Forum rules
Be Kind to other's.
No Cussing or Swearing.
Don't post anything Illegal or Obscene.
Image attachment size limit is 500 KiB.
rwensley
Posts: 29
Joined: Fri Oct 30, 2015 2:55 pm

Error Message

Postby rwensley » Mon Nov 09, 2015 9:18 pm

Greetings,

Over the week end I used PicSender many times making test and final engravings all without issue.
Tonight is a different story.

I am getting this error message see attached file,
'An unknown problem has been detected communicating with GRBL. Fix the problem, close and restart the program'

Strange as I can jog X, Y, and Z get status reports back and see command parameters all without issue showing that the communications are good

What I have done to remade;
1. Uninstalled and reinstalled Picsender
2. Rebooted PC
3. Tried a different cnc file
all to no avail.

Tried a different sender program and that works fine.

Reopened PicSender, jogged X Y and Z with no problem. Loaded the cnc file, Clicked Send and got the same error.
I also note that after the error the check boxes near the top change from'Position Sent' to 'Position Feedback' All else remains unchanged.

Please advise.
Ron Wensley
Attachments
sender_error.png
sender_error.png (3.22 KiB) Viewed 4996 times

rwensley
Posts: 29
Joined: Fri Oct 30, 2015 2:55 pm

Re: Error Message

Postby rwensley » Tue Nov 10, 2015 6:29 am

Well a new day and new ideas. So before going to work this morning I took another look at this.
I decided to clear the EEPROM, why I do not knw since the other sender program worked and PicSender could 'see' grbl most of the time.
I reloaded grbl and reinstalled my settings.
The result.
Now it is running fine again.
Conclusion, the UNO must of become scrabled somehow and would not work 100%. Great catch by PicSender.

Ron Wensley

User avatar
Picengravertoo
Full Access Moderator
Posts: 1092
Joined: Thu Dec 18, 2014 4:02 pm
Contact:

Re: Error Message

Postby Picengravertoo » Tue Nov 10, 2015 7:46 am

Hi Ron,

Are you using a counterfeit or knockoff UNO? We found them not to be very reliable.

Jeff

rwensley
Posts: 29
Joined: Fri Oct 30, 2015 2:55 pm

Re: Error Message

Postby rwensley » Tue Nov 10, 2015 8:17 am

Jeff,

I am using a genuine UNO R3. So I may have spoke too soon. I was doing a test run before leaving for work and 2:30ish into the run it stopped. PicSender would not respond and I had to use task manager to close it.

Cycled the power and usb on the uno, restarted all was well and then about 2:45 into the run it stopped again.

After work I will replace the uno with a new one and we share see what happens. I will also check the power supplies for the uno and usb to make sure there is nothing funky going on there.

Ron

User avatar
Picengravertoo
Full Access Moderator
Posts: 1092
Joined: Thu Dec 18, 2014 4:02 pm
Contact:

Re: Error Message

Postby Picengravertoo » Tue Nov 10, 2015 8:21 am

Hi Ron,

Do you have your USB Power Management disabled on your PC?

Jeff

rwensley
Posts: 29
Joined: Fri Oct 30, 2015 2:55 pm

Re: Error Message

Postby rwensley » Tue Nov 10, 2015 8:26 am

Jeff,

Yes I do, good thought. In this case I was doing other reading on the net while the test was running. Same as I was doing over the week end.
If the computer was 'going to sleep' during a run that would be an explanation. I will double check tonight.

Ron

rwensley
Posts: 29
Joined: Fri Oct 30, 2015 2:55 pm

Re: Error Message

Postby rwensley » Tue Nov 10, 2015 8:08 pm

No problem with PicSender only with the operator. I was experimenting with grbl settings and got carried away. As a result I scrambled the grbl's brain and well it did not like it.

I am glad that PicSender caught the issue. I also have learned a great deal about grbl in the past 24hrs.


Return to “PicSender”

Who is online

Users browsing this forum: No registered users and 4 guests

cron